Key cannot be null. Parameter name: key

Sep 16, 2010 at 12:37 AM

The web part initially worked, but then I suddenly received an error: "Key cannot be null. Parameter name: key". This appears where the table with the options should be (above the search field).

Also: there was one particular column I tried to add, but it wouldn't show up in the list of added columns. All the other columns worked, just not this particular one.

Any ideas?

Thanks

Coordinator
Sep 16, 2010 at 3:15 AM

 

Hi Andreas,

Let me tackle your second issue first - if the number of unique values in a column is more than 10, then the column won't get added to the list of selected columns. Now there is a setting for this, so in theory you can increase the limit to more than 10, but at the moment there is a bug that is ignoring that setting. I will be posting an update in the next couple of days that should fix this, ok?

Your first issue is a bit more tricky. What it means is that a variable that should have been there wasn't. Now that's very vague I know - because I've never seen that happen in testing. Can you reproduce the error?

Here is what I think *might* have happened: Several possibilities -

1. You had two browser windows open at the same time, and you reconfigured the web part in one window and then tried to use the web part in the other window. Now in that case I would *think* that SharePoint would simply throw a big ugly error and you'd have to reload the page (fixing the problem), but who knows.

2. It's possible that between loading the page and trying to use the web part, someone changed some column values or even deleted some library items. Again, I *think* that reloading the page should fix this, as I'm fairly sure that the web part re-scans the libraries for unique column values when the page loads.

3. If someone deleted one of the selected columns from the library it might happen too. In this case you'd have to reconfigure the web part (go to "modify web part", remove the selcted library and re-add it - that would be the safest way of getting the list of available columns to be correct).

Do any of these sound like they might be what happened? Can you let me know if you can reproduce the problem?

Thanks

Ron